aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-02-08 16:24:17 +1100
committerJustin Bedo <cu@cua0.org>2021-02-08 16:24:17 +1100
commit7de4d55d39fd39e1abb2b4bc8e0ba0d026bca54a (patch)
treef4a1bd5aae4afb9531814140a03b467f205055c2 /default.nix
parent801da8cf9560e1af468d7333f34cb98ae11934a7 (diff)
don't recursive update overlays
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 34059f1..0859085 100644
--- a/default.nix
+++ b/default.nix
@@ -190,8 +190,7 @@ let
overlayByType = {
lambda = bionix: overlay:
- bionix.extend
- (self: super: nixpkgs.lib.recursiveUpdate super (overlay self super));
+ bionix.extend overlay;
path = bionix: path: overlay bionix (import path);
};
overlay = bionix: overlay: