aboutsummaryrefslogtreecommitdiff
path: root/lib/references.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-02 15:35:22 +1100
committerJustin Bedo <cu@cua0.org>2018-11-02 15:40:27 +1100
commitf416c145204765a1566782f0ff384d3f65d6ed35 (patch)
tree0ce95603001956ac9941f95bd4870aa7a06cce28 /lib/references.nix
parentec77e9c3a9c2dc7425ee07474f525dd0a3d01fab (diff)
kallisto: init
Diffstat (limited to 'lib/references.nix')
-rwxr-xr-xlib/references.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/references.nix b/lib/references.nix
index 498cfd9..bdeefa6 100755
--- a/lib/references.nix
+++ b/lib/references.nix
@@ -46,6 +46,28 @@ rec {
'';
passthru.filetype = filetype.vcf { ref = seq; };
};
+ ensembl = {
+ cdna = stdenvNoCC.mkDerivation rec {
+ name = "ensembl-grch38-cdna-${version}";
+ version = "94";
+ src = fetchurl {
+ url = "ftp://ftp.ensembl.org/pub/release-${version}/fasta/homo_sapiens/cdna/Homo_sapiens.GRCh38.cdna.all.fa.gz";
+ sha256 = "1fc5d6p2wlwsm49wnmxmm3byjx5jvr6z9fpzrq7v7fpb086adl0h";
+ };
+ buildCommand = "gunzip < $src > $out";
+ passthru.filetype = filetype.fa {};
+ };
+ ncrna = stdenvNoCC.mkDerivation rec {
+ name = "ensembl-grch38-ncrna-${version}";
+ version = "94";
+ src = fetchurl {
+ url = "ftp://ftp.ensembl.org/pub/release-${version}/fasta/homo_sapiens/ncrna/Homo_sapiens.GRCh38.ncrna.fa.gz";
+ sha256 = "1cpasykwriila52nqgvw6d3mjyh6d9qi613hvhn4h1dxkqzgnjff";
+ };
+ buildCommand = "gunzip < $src > $out";
+ passthru.filetype = filetype.fa {};
+ };
+ };
};
grcm38 = grcm38-p6;