aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..75e06bd
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,22 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+let
+ style-check =
+ stdenv.mkDerivation rec {
+ name = "style-check";
+ src = fetchurl {
+ url = "http://www.cs.umd.edu/~nspring/software/style-check-current.tar.gz";
+ sha256 = "06g1ni28fdbrg2yaa6x8z3kg1mrjvhi48qv45hb80fwyrvy0ds1a";
+ };
+ installPhase = ''
+ make PREFIX=$out SYSCONFDIR=$out/etc/style-check.d/ install
+ sed -ie "s|/etc/style-check.d|$out/etc/style-check.d|g" $out/bin/style-check.rb
+ '';
+ buildInputs = [ ruby ];
+ };
+
+in mkShell {
+ buildInputs = with pkgs; [ (callPackage ./tex.nix {}) style-check proselint pandoc ];
+}