aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bwa-index.nix')
-rw-r--r--tools/bwa-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/bwa-index.nix b/tools/bwa-index.nix
index c879bc4..17b651f 100644
--- a/tools/bwa-index.nix
+++ b/tools/bwa-index.nix
@@ -1,19 +1,18 @@
{ bionix
-, nixpkgs
, flags ? null
}:
ref:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "bwa-index" { fa = _: true; } ref);
-stdenv.mkDerivation {
+stage {
name = "bwa-index";
- buildInputs = [ bwa ];
+ buildInputs = with pkgs; [ bwa ];
buildCommand = ''
ln -s ${ref} ref.fa
bwa index ${optionalString (flags != null) flags} ref.fa