aboutsummaryrefslogtreecommitdiff
path: root/tools/fastqc-check.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/fastqc-check.nix')
-rw-r--r--tools/fastqc-check.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/fastqc-check.nix b/tools/fastqc-check.nix
index d33b987..9b6dd96 100644
--- a/tools/fastqc-check.nix
+++ b/tools/fastqc-check.nix
@@ -9,12 +9,16 @@ input:
stage {
name = "fastqc-check";
- buildInputs = [ bionix.fastqc.fastqc ];
+ buildInputs = [ bionix.fastqc.fastqc pkgs.unzip ];
+ stripStorePaths = false; # we do it explicity for fastqc
+ outputs = [ "out" "zip" ];
buildCommand = ''
- mkdir $out
fastqc \
- -o $out \
+ -o $TMPDIR \
${optionalString (flags != null) flags} \
${input}
+
+ sed "s|$(basename ${input})|input|g" *.html > $out
+ cp *.zip $zip
'';
}