aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-assemble.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gridss-assemble.nix')
-rw-r--r--tools/gridss-assemble.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/gridss-assemble.nix b/tools/gridss-assemble.nix
index a8124e0..f57bc12 100644
--- a/tools/gridss-assemble.nix
+++ b/tools/gridss-assemble.nix
@@ -6,6 +6,7 @@
, collectMetricsAttrs ? {}
, flags ? null
, config ? null
+, heapSize ? "31g"
}:
with nixpkgs;
@@ -39,13 +40,14 @@ stdenv.mkDerivation rec {
name = "gridss-assemble";
buildInputs = [ jre bwa ];
buildCommand = ''
+ TMPDIR=$(pwd)
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx faidxAttrs ref} ref.fa.fai
for f in ${bionix.bwa.index bwaIndexAttrs ref}/*; do
ln -s $f
done
${concatMapStringsSep "\n" linkInput inputs}
- java -Xmx31g -Dsamjdk.create_index=true \
+ java -Xmx${heapSize} -Dsamjdk.create_index=true \
-cp ${bionix.gridss.jar} gridss.AssembleBreakends \
REFERENCE_SEQUENCE=ref.fa \
${concatMapStringsSep " " (i: "INPUT='${i}'") inputs} \