aboutsummaryrefslogtreecommitdiff
path: root/tools/gridss-variants.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gridss-variants.nix')
-rw-r--r--tools/gridss-variants.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/gridss-variants.nix b/tools/gridss-variants.nix
index a838da6..eb5957f 100644
--- a/tools/gridss-variants.nix
+++ b/tools/gridss-variants.nix
@@ -8,6 +8,7 @@
, softClipsToSplitReadsAttrs ? { flags = "REALIGN_ENTIRE_READ=true"; }
, flags ? null
, config ? null
+, heapSize ? "4g"
}:
with nixpkgs;
@@ -68,7 +69,7 @@ rec {
name = "gridss-identifyVariants";
buildInputs = [ jre samtools ];
buildCommand = mkLinks + ''
- java -Xmx4g -Dsamjdk.create_index=true \
+ java -Xmx${heapSize} -Dsamjdk.create_index=true \
-cp ${jar} gridss.IdentifyVariants \
REFERENCE_SEQUENCE=ref.fa \
${concatMapStringsSep " " (i: "INPUT='${i}'") inputs} \
@@ -91,7 +92,7 @@ rec {
buildInputs = [ jre ];
buildCommand = mkLinks + ''
ln -s ${identify} input.vcf
- java -Xmx4g -Dsamjdk.create_index=true \
+ java -Xmx${heapSize} -Dsamjdk.create_index=true \
-cp ${jar} gridss.AnnotateVariants \
REFERENCE_SEQUENCE=ref.fa \
${concatMapStringsSep " " (i: "INPUT='${i}'") inputs} \