aboutsummaryrefslogtreecommitdiff
path: root/tools/kallisto-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/kallisto-index.nix')
-rw-r--r--tools/kallisto-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/kallisto-index.nix b/tools/kallisto-index.nix
index 33dfb80..3b92d38 100644
--- a/tools/kallisto-index.nix
+++ b/tools/kallisto-index.nix
@@ -1,11 +1,10 @@
{bionix
-, nixpkgs
, kmerSize ? 31
, unique ? false}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (kmerSize > 1);
@@ -13,9 +12,9 @@ input:
assert (matchFiletype input { fa = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "kallisto-index";
- buildInputs = [ kallisto ];
+ buildInputs = with pkgs; [ kallisto ];
buildCommand = ''
kallisto index -k ${toString kmerSize} ${optionalString unique "--make-unique"} -i $out ${input}
'';