aboutsummaryrefslogtreecommitdiff
path: root/tools/kallisto-quant.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/kallisto-quant.nix')
-rw-r--r--tools/kallisto-quant.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/kallisto-quant.nix b/tools/kallisto-quant.nix
index c410721..1deab67 100644
--- a/tools/kallisto-quant.nix
+++ b/tools/kallisto-quant.nix
@@ -1,5 +1,4 @@
{bionix
-, nixpkgs
, indexFlags ? {}
, bias ? false
, bootstrapSamples ? 0
@@ -13,7 +12,7 @@
, fragmentSD ? null
, ref}:
-with nixpkgs;
+with bionix;
with lib;
assert (!single || (fragmentLength != null && fragmentSD != null));
@@ -27,9 +26,9 @@ in
assert (all (x: isFastQ (x.filetype)) inputs);
-stdenv.mkDerivation {
+stage {
name = "kallisto-quant";
- buildInputs = [ kallisto ];
+ buildInputs = with pkgs; [ kallisto ];
buildCommand = ''
mkdir $out
kallisto quant \