aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-depth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mosdepth-depth.nix')
-rw-r--r--tools/mosdepth-depth.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/mosdepth-depth.nix b/tools/mosdepth-depth.nix
new file mode 100644
index 0000000..3340872
--- /dev/null
+++ b/tools/mosdepth-depth.nix
@@ -0,0 +1,14 @@
+{ stdenv
+, mosdepth
+, flags ? null}:
+
+input:
+
+stdenv.mkDerivation {
+ name = "mosdepth-depth";
+ buildInputs = [ mosdepth ];
+ buildCommand = ''
+ mkdir $out
+ mosdepth -t $NIX_BUILD_CORES ${optionalString (flags != null) flags} $out/out ${input}
+ '';
+}