aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-depth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mosdepth-depth.nix')
-rw-r--r--tools/mosdepth-depth.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/mosdepth-depth.nix b/tools/mosdepth-depth.nix
index 7043c43..448da11 100644
--- a/tools/mosdepth-depth.nix
+++ b/tools/mosdepth-depth.nix
@@ -1,17 +1,16 @@
{ bionix
-, nixpkgs
, indexAttrs ? {}
, flags ? null
}:
-with nixpkgs;
+with bionix;
with lib;
input:
-stdenv.mkDerivation {
+stage {
name = "mosdepth-depth";
- buildInputs = [ mosdepth ];
+ buildInputs = with pkgs; [ mosdepth ];
buildCommand = ''
mkdir $out
ln -s ${input} input.bam