aboutsummaryrefslogtreecommitdiff
path: root/tools/mosdepth-plot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mosdepth-plot.nix')
-rw-r--r--tools/mosdepth-plot.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/mosdepth-plot.nix b/tools/mosdepth-plot.nix
new file mode 100644
index 0000000..464e495
--- /dev/null
+++ b/tools/mosdepth-plot.nix
@@ -0,0 +1,15 @@
+{ stdenv
+, mosdepth
+, python
+, flags ? null}:
+
+input:
+
+stdenv.mkDerivation {
+ name = "mosdepth-depth";
+ buildInputs = [ python ];
+ buildCommand = ''
+ python ${mosdepth.src}/scripts/plot-dist.py ${input}/*global.dist.txt
+ mv dist.html $out
+ '';
+}