aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-merge.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/samtools-merge.nix')
-rw-r--r--tools/samtools-merge.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/tools/samtools-merge.nix b/tools/samtools-merge.nix
index eacf520..120f825 100644
--- a/tools/samtools-merge.nix
+++ b/tools/samtools-merge.nix
@@ -1,12 +1,11 @@
{ bionix
-, nixpkgs
, flags ? null
, outfmt ? null
}:
inputs:
-with nixpkgs;
+with bionix;
with lib;
let
@@ -16,9 +15,9 @@ in
assert inputIsHomogenous;
-stdenv.mkDerivation {
+stage {
name = "samtools-merge";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools merge ${optionalString (flags != null) flags} $out ${concatStringsSep " " inputs}
'';