aboutsummaryrefslogtreecommitdiff
path: root/tools/samtools-view.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/samtools-view.nix')
-rw-r--r--tools/samtools-view.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/samtools-view.nix b/tools/samtools-view.nix
index b791534..e1ca0a8 100644
--- a/tools/samtools-view.nix
+++ b/tools/samtools-view.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, nameSort ? false
, flags ? null
, outfmt ? null
@@ -7,9 +6,9 @@
input:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "samtools-view" { bam = _: true; sam = _: true; cram = _: true; } input);
@@ -17,9 +16,9 @@ let
outfmtR = if outfmt != null then outfmt input else input.filetype;
fa = ref: matchFiletype "samtools-view-ref" { fa = _: ref; } ref;
outfmtFlags = matchFiletype "samtools-view-outfmt" { bam = _: "-O BAM"; sam = _: "-O SAM"; cram = x: "-O CRAM -T ${fa x.ref}"; } {filetype = outfmtR;};
-in stdenv.mkDerivation {
+in stage {
name = "samtools-view";
- buildInputs = [ samtools ];
+ buildInputs = with pkgs; [ samtools ];
buildCommand = ''
samtools view ${outfmtFlags} ${optionalString (flags != null) flags} ${input} > $out
'';