aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-annotate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/snpeff-annotate.nix')
-rw-r--r--tools/snpeff-annotate.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/snpeff-annotate.nix b/tools/snpeff-annotate.nix
new file mode 100644
index 0000000..a119c3c
--- /dev/null
+++ b/tools/snpeff-annotate.nix
@@ -0,0 +1,21 @@
+{bionix
+,nixpkgs
+,db
+,flags ? ""}:
+
+input:
+
+with nixpkgs;
+with bionix.types;
+
+assert (matchFiletype "snpeff-annotate" { vcf = _: true; } input);
+
+stdenv.mkDerivation {
+ name = "snpeff-annotate";
+ buildCommand = ''
+ ln -s ${db} ${db.name}
+ snpeff -nodownload -dataDir $TMPDIR ${db.name} ${input} > $out
+ '';
+ buildInputs = [ snpeff ];
+ passthru.filetype = input.filetype;
+}