aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff-annotate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/snpeff-annotate.nix')
-rw-r--r--tools/snpeff-annotate.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/snpeff-annotate.nix b/tools/snpeff-annotate.nix
index a119c3c..dee99f1 100644
--- a/tools/snpeff-annotate.nix
+++ b/tools/snpeff-annotate.nix
@@ -1,21 +1,20 @@
{bionix
-,nixpkgs
,db
,flags ? ""}:
input:
-with nixpkgs;
-with bionix.types;
+with bionix;
+with types;
assert (matchFiletype "snpeff-annotate" { vcf = _: true; } input);
-stdenv.mkDerivation {
+stage {
name = "snpeff-annotate";
+ buildInputs = with pkgs; [ snpeff ];
buildCommand = ''
ln -s ${db} ${db.name}
snpeff -nodownload -dataDir $TMPDIR ${db.name} ${input} > $out
'';
- buildInputs = [ snpeff ];
passthru.filetype = input.filetype;
}