aboutsummaryrefslogtreecommitdiff
path: root/tools/star-align.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/star-align.nix')
-rw-r--r--tools/star-align.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/star-align.nix b/tools/star-align.nix
index 0cf9ab9..44dd7f2 100644
--- a/tools/star-align.nix
+++ b/tools/star-align.nix
@@ -33,6 +33,6 @@ in stage {
--readFilesIn ${fq input1} ${optionalString (input2 != null) (fq input2)}
${if bamOutput then "samtools view -b Aligned.out.sam > $out" else "cp Aligned.out.sam $out"}
'';
- passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.name {};} else filetype.sam {ref = ref; sorting = sort.name {};};
+ passthru.filetype = if bamOutput then filetype.bam {ref = ref; sorting = sort.none {};} else filetype.sam {ref = ref; sorting = sort.name {};};
passthru.multicore = true;
}