aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-call.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/strelka-call.nix')
-rw-r--r--tools/strelka-call.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/strelka-call.nix b/tools/strelka-call.nix
index bcbb6d1..95ce0f6 100644
--- a/tools/strelka-call.nix
+++ b/tools/strelka-call.nix
@@ -1,5 +1,4 @@
{ bionix
-, nixpkgs
, indexAttrs ? {}
, bamIndexAttrs ? {}
, flags ? null
@@ -7,9 +6,9 @@
{normal, tumour}:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
let
filename = path: last (splitString "/" path);
@@ -22,9 +21,9 @@ in
assert (length (unique refs) == 1);
-stdenv.mkDerivation {
+pkgs.stdenv.mkDerivation {
name = "strelka";
- buildInputs = [ strelka ];
+ buildInputs = with pkgs; [ strelka ];
buildCommand = ''
ln -s ${ref} ref.fa
ln -s ${bionix.samtools.faidx indexAttrs ref} ref.fa.fai