summaryrefslogtreecommitdiff
path: root/pkgs/mx-puppet-groupme/generate.sh
diff options
context:
space:
mode:
authorParthiv Seetharaman <pachum99@myrdd.info>2022-01-16 21:29:21 -0800
committerParthiv Seetharaman <pachum99@myrdd.info>2022-01-16 21:44:42 -0800
commit8c05a809d70aeeb6c6e23d405ba693040ad00730 (patch)
tree70cc604e5eeb943e15c925f8e0c4d6d1eae8ed7c /pkgs/mx-puppet-groupme/generate.sh
init the module, README, packages, and other stuff
Diffstat (limited to 'pkgs/mx-puppet-groupme/generate.sh')
-rwxr-xr-xpkgs/mx-puppet-groupme/generate.sh16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/mx-puppet-groupme/generate.sh b/pkgs/mx-puppet-groupme/generate.sh
new file mode 100755
index 0000000..90f3ca8
--- /dev/null
+++ b/pkgs/mx-puppet-groupme/generate.sh
@@ -0,0 +1,16 @@
+#! nix-shell -i bash -p nodePackages.node2nix
+
+# No official release
+rev="695f97c3ab834403489bb01517d433498118e482"
+u="https://gitlab.com/robintown/mx-puppet-groupme/-/raw/$rev"
+# Download package.json and package-lock.json
+# curl -o package.json "$u/package.json?inline=false"
+curl -o package-lock.json "$u/package-lock.json?inline=false"
+
+node2nix \
+ --nodejs-12 \
+ --node-env node-env.nix \
+ --input package.json \
+ --lock package-lock.json \
+ --output node-packages.nix \
+ --composition node-composition.nix