summaryrefslogtreecommitdiff
path: root/pkgs/mx-puppet-slack/generate.sh
diff options
context:
space:
mode:
authorParthiv Seetharaman <pachum99@myrdd.info>2022-01-16 21:29:21 -0800
committerParthiv Seetharaman <pachum99@myrdd.info>2022-01-16 21:44:42 -0800
commit8c05a809d70aeeb6c6e23d405ba693040ad00730 (patch)
tree70cc604e5eeb943e15c925f8e0c4d6d1eae8ed7c /pkgs/mx-puppet-slack/generate.sh
init the module, README, packages, and other stuff
Diffstat (limited to 'pkgs/mx-puppet-slack/generate.sh')
-rwxr-xr-xpkgs/mx-puppet-slack/generate.sh24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/mx-puppet-slack/generate.sh b/pkgs/mx-puppet-slack/generate.sh
new file mode 100755
index 0000000..d36f515
--- /dev/null
+++ b/pkgs/mx-puppet-slack/generate.sh
@@ -0,0 +1,24 @@
+#!/usr/bin/env bash
+
+
+#!/usr/bin/env nix-shell
+#! nix-shell -i bash -p nodePackages.node2nix
+
+# No official release
+rev=691e53d2d703bd169e1f23a8d8dff3f008d8c4ef
+u=https://raw.githubusercontent.com/Sorunome/mx-puppet-slack/$rev
+# Download package.json and package-lock.json
+curl -O $u/package.json
+curl -O $u/package-lock.json
+
+node2nix \
+ --nodejs-12 \
+ --node-env node-env.nix \
+ --input package.json \
+ --lock package-lock.json \
+ --output node-packages.nix \
+ --composition node-composition.nix
+
+sed -i 's|<nixpkgs>|../../..|' node-composition.nix
+
+rm -f package.json package-lock.json