summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..9d62c95
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,15 @@
+let
+ inherit (import
+ (
+ let lock = builtins.fromJSON (builtins.readFile ./flake.lock); in
+ fetchTarball {
+ url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+ sha256 = lock.nodes.flake-compat.locked.narHash;
+ }
+ )
+ { src = ./.; }
+ ) defaultNix;
+in
+ # Pass this flake as inputs.self
+ defaultNix // { inputs = defaultNix.inputs // { self = defaultNix; }; }
+