summaryrefslogtreecommitdiff
path: root/pkgs/mautrix-syncproxy
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/mautrix-syncproxy')
-rw-r--r--pkgs/mautrix-syncproxy/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/mautrix-syncproxy/default.nix b/pkgs/mautrix-syncproxy/default.nix
new file mode 100644
index 0000000..1145280
--- /dev/null
+++ b/pkgs/mautrix-syncproxy/default.nix
@@ -0,0 +1,31 @@
+{ lib, buildGoModule, fetchFromGitHub, olm }:
+
+buildGoModule rec {
+ pname = "mautrix-syncproxy-bin";
+ version = "unstable-2021-08-31";
+
+ src = fetchFromGitHub {
+ owner = "mautrix";
+ repo = "syncproxy";
+ rev = "808118c0daa684f3d82f28efc6b6d8ef70e1a4af";
+ sha256 = "sha256-CDzeJm0hTErLQwcPAvsnCYT2LZlv7iAXHmdMF9ZiK8Y=";
+ };
+
+ vendorSha256 = "sha256-ni1fcNNeaTBkfwNFztzmEAgA0v5a6sWoo93CvHQkvVA=";
+
+ doCheck = false;
+
+ proxyVendor = true;
+
+ postInstall = ''
+ mv $out/bin/mautrix-syncproxy $out/bin/mautrix-syncproxy-bin
+ '';
+
+ meta = with lib; {
+ homepage = "https://github.com/mautrix/syncproxy";
+ description = "A /sync proxy for encrypted Matrix appservices.";
+ mainProgram = "mautrix-syncproxy-bin";
+ license = licenses.agpl3Plus;
+ maintainers = with maintainers; [ ];
+ };
+}