diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 19 |
1 files changed, 10 insertions, 9 deletions
@@ -1,12 +1,13 @@ -let - pkgs = import <nixpkgs> { }; +{ mkShell, ghc, haskell, biohazardSrc }: - ghc = with pkgs.haskell.lib; - pkgs.ghc.withPackages (pkgs: - with pkgs; - [ +let + ghcP = with haskell.lib; + ghc.withPackages (pkgs: + with pkgs; [ hlint - (doJailbreak (markUnbroken - (biohazard.overrideAttrs (_: { patches = [ ./biohazard.patch ]; })))) + (doJailbreak (markUnbroken (biohazard.overrideAttrs (_: { + src = biohazardSrc; + patches = [ ./biohazard.patch ]; + })))) ]); -in pkgs.mkShell { buildInputs = [ ghc ]; } +in mkShell { buildInputs = [ ghcP ]; } |