aboutsummaryrefslogtreecommitdiff
path: root/day2/ex5-bwa/flake.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2022-10-10 13:22:03 +1100
committerJustin Bedo <cu@cua0.org>2022-10-12 09:09:01 +1100
commitac3a4e0363c1fde0f1dbff75b95aa27d9acd5e5e (patch)
tree117083afffdc77dfa0b768901338b93999550bb8 /day2/ex5-bwa/flake.nix
parent059034ab3d5c40c8ef0350c440d4ae343802ec5c (diff)
insert exercise 4
Diffstat (limited to 'day2/ex5-bwa/flake.nix')
-rwxr-xr-xday2/ex5-bwa/flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/day2/ex5-bwa/flake.nix b/day2/ex5-bwa/flake.nix
new file mode 100755
index 0000000..bfaca96
--- /dev/null
+++ b/day2/ex5-bwa/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ bionix.url = "github:papenfusslab/bionix";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ bionix,
+ flake-utils,
+ }:
+ flake-utils.lib.eachDefaultSystem (system: let
+ pkgs = import nixpkgs {inherit system;};
+ bionix' = import bionix {nixpkgs = pkgs;};
+ in {
+ defaultPackage = bionix'.callBionix ./. {};
+ });
+}