aboutsummaryrefslogtreecommitdiff
path: root/day2/ex1-hello-world/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'day2/ex1-hello-world/default.nix')
-rw-r--r--day2/ex1-hello-world/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/day2/ex1-hello-world/default.nix b/day2/ex1-hello-world/default.nix
new file mode 100644
index 0000000..8eaffa7
--- /dev/null
+++ b/day2/ex1-hello-world/default.nix
@@ -0,0 +1,22 @@
+/*
+ This first exercise demonstrates how to define a processing stage,
+which is just instructions on how to compute an output (the
+`buildCommand`) from some inputs (in this case, there are no inputs).
+Each stage must minimally define a `name`, shell code to build the
+output in `buildCommand`, and any software that's required in
+`buildInputs`. Note that `buildInputs = []` if not defined, meaning no
+extra requirements over the standard environment.
+
+Try replacing the echo below with output from the GNU hello program.
+Hint: the GNU hello program is available at `pkgs.hello` and the
+executable is called `hello`.
+*/
+{bionix}:
+with bionix;
+ stage {
+ name = "hello-world";
+
+ buildCommand = ''
+ echo hello world > $out
+ '';
+ }