aboutsummaryrefslogtreecommitdiff
path: root/day2/ex3-R/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'day2/ex3-R/flake.nix')
-rwxr-xr-xday2/ex3-R/flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/day2/ex3-R/flake.nix b/day2/ex3-R/flake.nix
new file mode 100755
index 0000000..bfaca96
--- /dev/null
+++ b/day2/ex3-R/flake.nix
@@ -0,0 +1,20 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ bionix.url = "github:papenfusslab/bionix";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ bionix,
+ flake-utils,
+ }:
+ flake-utils.lib.eachDefaultSystem (system: let
+ pkgs = import nixpkgs {inherit system;};
+ bionix' = import bionix {nixpkgs = pkgs;};
+ in {
+ defaultPackage = bionix'.callBionix ./. {};
+ });
+}