aboutsummaryrefslogtreecommitdiff
path: root/day2/ex3-R/solution.nix
diff options
context:
space:
mode:
Diffstat (limited to 'day2/ex3-R/solution.nix')
-rw-r--r--day2/ex3-R/solution.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/day2/ex3-R/solution.nix b/day2/ex3-R/solution.nix
new file mode 100644
index 0000000..7d40f88
--- /dev/null
+++ b/day2/ex3-R/solution.nix
@@ -0,0 +1,19 @@
+{bionix}:
+with bionix; let
+ R = pkgs.rWrapper.override {packages = with pkgs.rPackages; [edgeR];};
+
+ counts = pkgs.fetchurl {
+ url = "https://raw.githubusercontent.com/ucdavis-bioinformatics-training/2018-September-Bioinformatics-Prerequisites/master/friday/counts.tsv";
+ sha256 = "sha256-ZmZ+vC4mKnmZKVJqbnEujDngwnSTZAxvQaZaNClUUWE=";
+ };
+in
+ stage {
+ inherit counts;
+ name = "r-ex";
+
+ buildInputs = [R];
+
+ buildCommand = ''
+ Rscript ${./script.R}
+ '';
+ }