aboutsummaryrefslogtreecommitdiff
path: root/day2/ex4-scanpy/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'day2/ex4-scanpy/flake.nix')
-rwxr-xr-xday2/ex4-scanpy/flake.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/day2/ex4-scanpy/flake.nix b/day2/ex4-scanpy/flake.nix
new file mode 100755
index 0000000..9587213
--- /dev/null
+++ b/day2/ex4-scanpy/flake.nix
@@ -0,0 +1,38 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/release-21.11";
+ bionix.url = "github:papenfusslab/bionix";
+ flake-utils.url = "github:numtide/flake-utils";
+
+ mach-nix = {
+ url = "mach-nix/3.5.0";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
+ pypi-deps-db.follows = "pypi-deps-db";
+ };
+ };
+
+ pypi-deps-db = {
+ url = "github:DavHau/pypi-deps-db";
+ flake = false;
+ };
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ bionix,
+ flake-utils,
+ mach-nix,
+ ...
+ }:
+ flake-utils.lib.eachDefaultSystem (system: let
+ pkgs = import nixpkgs {
+ inherit system;
+ };
+ bionix' = import bionix {nixpkgs = pkgs;};
+ in {
+ defaultPackage = bionix'.callBionix ./. {mach-nix = mach-nix.lib."${system}";};
+ });
+}