aboutsummaryrefslogtreecommitdiff
path: root/day2/ex5-bwa/solution.nix
diff options
context:
space:
mode:
Diffstat (limited to 'day2/ex5-bwa/solution.nix')
-rw-r--r--day2/ex5-bwa/solution.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/day2/ex5-bwa/solution.nix b/day2/ex5-bwa/solution.nix
new file mode 100644
index 0000000..79fc7dc
--- /dev/null
+++ b/day2/ex5-bwa/solution.nix
@@ -0,0 +1,19 @@
+{bionix}:
+with bionix; let
+ input = {
+ input1 = fetchFastQ {
+ url = "https://raw.githubusercontent.com/PapenfussLab/bionix/master/examples/sample1-1.fq";
+ sha256 = "sha256-qE6s8hKowiz3mvCq8/7xAzUz77xG9rAcsI2E50xMAk4=";
+ };
+ input2 = fetchFastQ {
+ url = "https://raw.githubusercontent.com/PapenfussLab/bionix/master/examples/sample1-2.fq";
+ sha256 = "sha256-s02R49HX/qeJp4t/eZwsKwV9D07uLGId8CEpU2dB8zM=";
+ };
+ };
+
+ ref = fetchFastA {
+ url = "https://raw.githubusercontent.com/PapenfussLab/bionix/master/examples/ref.fa";
+ sha256 = "sha256-V3zqOJFuGtukDRQttK/pGfKofgOlKrridHaWYhGGyWs=";
+ };
+in
+ samtools.sort {} (bwa.align {inherit ref;} input)