aboutsummaryrefslogtreecommitdiff
path: root/conda.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-05 13:36:45 +1000
committerJustin Bedo <cu@cua0.org>2018-09-05 13:36:45 +1000
commit24d24d7c0ddb3e3406c46b5fe2524abec2c58079 (patch)
tree6a41cf325d18a7007b013f0cad44ebb6ae65361d /conda.nix
parenta74b705e5dc8870c2516b8dfa71d7a510b4d4246 (diff)
conda proof of concept
Diffstat (limited to 'conda.nix')
-rw-r--r--conda.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/conda.nix b/conda.nix
new file mode 100644
index 0000000..4006218
--- /dev/null
+++ b/conda.nix
@@ -0,0 +1,19 @@
+{pkgs ? import <nixpkgs> {}}:
+
+with pkgs;
+
+stdenv.mkDerivation {
+ name = "conda";
+ src = ./conda.nix;
+ phases = [ "buildPhase" ];
+ buildInputs = [ conda ];
+ buildPhase = ''
+ HOME=$TMPDIR
+ conda-shell-4.3.31 << EOF
+ conda-install
+ conda config --add channels bioconda
+ conda install -y bwa
+ bwa
+ EOF
+ '';
+}