aboutsummaryrefslogtreecommitdiff
path: root/conda.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-06 08:28:51 +1000
committerJustin Bedo <cu@cua0.org>2018-09-06 08:28:51 +1000
commit415c38f9fe497b90c9ca53fce0c0599ea71d05ea (patch)
tree60353563913d1d71a22d9334952f5ac5d6f2973a /conda.nix
parentd7b738eea555bb63026279589d4b835f8459b9f0 (diff)
renamed and fixed depends
Diffstat (limited to 'conda.nix')
-rw-r--r--conda.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/conda.nix b/conda.nix
index daffc8e..bbcb7cf 100644
--- a/conda.nix
+++ b/conda.nix
@@ -3,7 +3,7 @@
{
buildCondaEnv = { depends ? [], run }: stdenv.mkDerivation {
name = "conda-env";
- buildInputs = [ conda ] ++ depends;
+ propagatedBuildInputs = [ conda ] ++ depends;
buildCommand = ''
mkdir $out
HOME=$out
@@ -14,7 +14,7 @@
'';
};
- withCondaEnv = env: run: stdenv.mkDerivation {
+ inCondaEnv = env: run: stdenv.mkDerivation {
name = "with-conda-env";
buildCommand = ''
#!${stdenv.shell}