aboutsummaryrefslogtreecommitdiff
path: root/conda.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-04-30 09:47:49 +1000
committerJustin Bedo <cu@cua0.org>2019-04-30 09:47:49 +1000
commita1d18efc18772a233aa759b622c3a9960824f109 (patch)
treec8e4028b4b634cfe7002c79539563256894e0d48 /conda.nix
parente9b908b0cdc22a7b43301e63a23c7911aa371721 (diff)
cleanup examples and stray files
Diffstat (limited to 'conda.nix')
-rw-r--r--conda.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/conda.nix b/conda.nix
deleted file mode 100644
index bbcb7cf..0000000
--- a/conda.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, lib, writeScript, conda }:
-
-{
- buildCondaEnv = { depends ? [], run }: stdenv.mkDerivation {
- name = "conda-env";
- propagatedBuildInputs = [ conda ] ++ depends;
- buildCommand = ''
- mkdir $out
- HOME=$out
- conda-shell-4.3.31 << EOF
- conda-install
- ${run}
- EOF
- '';
- };
-
- inCondaEnv = env: run: stdenv.mkDerivation {
- name = "with-conda-env";
- buildCommand = ''
- #!${stdenv.shell}
- export HOME=${env}
- ${conda}/bin/conda-shell-4.3.31 << EOF
- ${run}
- EOF
- '';
- };
-}
-