aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-02-06 10:18:20 +1100
committerJustin Bedo <cu@cua0.org>2019-02-06 10:27:52 +1100
commit5e2c7c85d001fde0600e77bfbd9d1078fcd561f4 (patch)
treec4ed092a5c45858f44dbaf17defd7d14dc019c9c /default.nix
parent71a9142f58f0e9e738ca1450b91b4672ed41521d (diff)
qsub: parameterise queue and allow arbitrary flags to be passed
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index f3a582b..bd68277 100644
--- a/default.nix
+++ b/default.nix
@@ -32,7 +32,7 @@ let
strelka = callBionix ./tools/strelka.nix {};
qsub = attrs: bionix.extend (self: super: with self; rec {
- qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; } // attrs;
+ qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; queue = null; flags = null; } // attrs;
qsub = attrs: (callPackage ./lib/qsub.nix {}) (qsubDefs // attrs);
exec = f: x: y: qsub (builtins.intersectAttrs qsubDefs x) (f (builtins.removeAttrs x (builtins.attrNames qsubDefs)) y);
});