aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-12-18 17:18:15 +1100
committerJustin Bedo <cu@cua0.org>2018-12-18 17:18:15 +1100
commit74b84ea649f2b34e038d069d9e4f904230571ea4 (patch)
treeb0d7e62ece8cb6e987c1e482886ec1456538ae41 /default.nix
parent4d2b5043f8d7d56aeb94d11218e4ae5cda1662d1 (diff)
pipe: fix bug
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 42dd286..84bb3c8 100644
--- a/default.nix
+++ b/default.nix
@@ -35,7 +35,7 @@ let
exec = f: x: y: qsub (builtins.intersectAttrs qsubDefs x) (f (builtins.removeAttrs x (builtins.attrNames qsubDefs)) y);
});
def = f: defs: attrs: f (defs // attrs);
- pipe = let g = fs: with builtins; let h = head fs; t = tail fs; in if t != [] then x: (g t (h x)) else h; in g
+ pipe = let g = fs: with builtins; let h = head fs; t = tail fs; in if t != [] then x: (g t (h x)) else h; in g;
# Fetching files of specific type
fetchFastQ = attrs: with types; tagFiletype (filetype.fq {}) (fetchurl attrs);