aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-04-07 08:29:11 +1000
committerJustin Bedo <cu@cua0.org>2019-04-07 08:29:11 +1000
commit761d47937eeb6787ff807c34be7a3623a4bde0e9 (patch)
tree03b197388312ff4d7ccb1e53d93181e76664ff7e /default.nix
parentdbbfc5655b840e9cd1d10993b411376ec0a90135 (diff)
update stage names to include bionix- prefix
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 736eef0..7b49279 100644
--- a/default.nix
+++ b/default.nix
@@ -63,7 +63,7 @@ let
# Export nixpkgs and standard library lib
pkgs = nixpkgs;
lib = nixpkgs.lib // { types = types; };
- stage = x: { multicore = false; } // nixpkgs.stdenvNoCC.mkDerivation x;
+ stage = x@{ name, ... }: { multicore = false; } // nixpkgs.stdenvNoCC.mkDerivation (x // {name = "bionix-" + name;});
# splitting/joining
splitFile = file: drv: stage {