aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-03-27 10:28:44 +1100
committerJustin Bedo <cu@cua0.org>2020-03-27 10:28:44 +1100
commit7a80f94a3aa69072e25b92098a746778707cb7d6 (patch)
tree923efa3dbbe08047a5343a1f36bb0d8fe38b197a /default.nix
parent57ccba7da6feb46475f1ad58126a663356efe358 (diff)
pipe now part of nixpkgs
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index ad8cecc..a8551d6 100644
--- a/default.nix
+++ b/default.nix
@@ -58,7 +58,6 @@ let
exec = f: x: y: qsub (builtins.intersectAttrs qsubDefs x) (super.exec f (builtins.removeAttrs x (builtins.attrNames qsubDefs)) y);
});
def = f: defs: attrs: f (defs // attrs);
- pipe = let g = fs: with builtins; let h = head fs; t = tail fs; in if t != [] then x: (g t (h x)) else h; in g;
linkOutputs = x: with lib; nixpkgs.stdenvNoCC.mkDerivation {
name = "link-outputs";