aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorl-d-s <distefano.l@wehi.edu.au>2018-11-22 12:04:23 +1100
committerl-d-s <distefano.l@wehi.edu.au>2018-11-22 12:04:23 +1100
commit7c36ee4ec628767c834ad803aac76d93e31f0486 (patch)
tree2edf423614fc077c4027b7996f690b004ec4f25b /default.nix
parent3c568bacd397a3ddcb203811f7fa5a1f8af760a3 (diff)
parent0ade062d2da8a7111b14aa3d72ef7c741e98352d (diff)
Merge branch 'master' of https://github.com/PapenfussLab/bionix
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index f835fa0..50b85a3 100644
--- a/default.nix
+++ b/default.nix
@@ -1,6 +1,8 @@
{nixpkgs ? import <nixpkgs> {}}:
let
+ inherit (nixpkgs) fetchurl;
+
bionix = nixpkgs.lib.makeExtensible (self:
let callBionix = file: attrs: import file ({ bionix = self; nixpkgs = nixpkgs; } // attrs);
in with self; {
@@ -29,5 +31,12 @@ let
def = f: defs: attrs: f (defs // attrs);
defQsub = qsubAttrs: f: defs: qsubAttr qsubAttrs (def f defs);
+ # Fetching files of specific type
+ fetchFastQ = attrs: with types; tagFiletype (filetype.fq {}) (fetchurl attrs);
+ fetchFastA = attrs: with types; tagFiletype (filetype.fa {}) (fetchurl attrs);
+ fetchFastQGZ = attrs: with types; tagFiletype (filetype.gz (filetype.fq {})) (fetchurl attrs);
+ fetchFastAGZ = attrs: with types; tagFiletype (filetype.gz (filetype.fa {})) (fetchurl attrs);
+
+
});
in bionix