aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-04-22 13:48:18 +1000
committerJustin Bedo <cu@cua0.org>2020-04-22 13:48:18 +1000
commit98501e58830a93b531a1a5a172d666e66e6b4a6a (patch)
treef4eef8c836fb1f4fd9515fd0a8cdeae80fe83973 /default.nix
parent05b53839802c91d301f1f5168fdcbb8de1d8549c (diff)
fix error message for linkOutputs
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index a8551d6..98b2e5a 100644
--- a/default.nix
+++ b/default.nix
@@ -66,7 +66,7 @@ let
buildCommand = let
recurse = x: if x ? type && x.type == "derivation" then x else
if builtins.typeOf x == "set" then linkOutputs x
- else error "linkOutputs: unsupported type";
+ else abort "linkOutputs: unsupported type";
link = dst: src: ''
ln -s ${recurse src} $(perl -e 'print $ENV{"${dst}"}') ; ln -s ${recurse src} $out/${dst}
'';