aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
committerJustin Bedo <cu@cua0.org>2018-09-26 10:53:53 +1000
commit98672cb1bba7221c5c8ecc363243cb47fcd13f47 (patch)
treec5c73fc08323a8350a0ba80aae7a7232fed19171 /default.nix
parent45af0256cf75fa28e75b6cf6874df0c48aac38cf (diff)
refactor, add mosdepth, and fixes for bwa
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..a9fb72b
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,14 @@
+{nixpkgs ? import <nixpkgs> {}}:
+
+let
+ bionix = nixpkgs.lib.makeExtensible (self:
+ let callBionix = file: import file { bionix = self; nixpkgs = nixpkgs; };
+ in with self; {
+ bwa = callBionix ./tools/bwa.nix;
+ mosdepth = callBionix ./tools/mosdepth.nix;
+ platypus = callBionix ./tools/platypus.nix;
+ ref = callBionix ./references.nix;
+ samtools = callBionix ./tools/samtools.nix;
+ strelka = callBionix ./tools/strelka.nix;
+ });
+in bionix