aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-07-26 09:04:43 +1000
committerJustin Bedo <cu@cua0.org>2019-07-26 09:07:25 +1000
commitac299f45add87dd7158776f8f8baf4139a30566a (patch)
treecfbce4f1bc1a5db668ae3096ab2fe12c151a6ada /default.nix
parent5cdc23b7e62d1d0be67047ff95cd74e570a65922 (diff)
make stripping more liberal
Update the regex so that /nix/store* prefix doesn't have to match. To make sure we aren't overly general, we strip only bionix stages (i.e., -bionix suffix has to be present in the hash).
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 36dbe44..23e4f9b 100644
--- a/default.nix
+++ b/default.nix
@@ -83,7 +83,7 @@ let
stripCommand = ''
function rewrite {
- sed -i 's|/nix/store/[^-]*|/nix/store/00000000000000000000000000000000|g' $1
+ sed -i 's|[A-Za-z0-9+/]\{32\}-bionix|00000000000000000000000000000000-bionix|g' $1
}
function rewriteOutput {
if [ -f ''${!1} ] ; then