aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /default.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 6ddcd1b..c50e063 100644
--- a/default.nix
+++ b/default.nix
@@ -4,7 +4,7 @@ let
inherit (nixpkgs) fetchurl callPackage;
bionix = nixpkgs.lib.makeExtensible (self:
- let callBionix = file: attrs: import file ({ bionix = self; nixpkgs = nixpkgs; } // attrs);
+ let callBionix = file: attrs: import file ({ bionix = self; } // attrs);
in with self; {
callBionix = callBionix;
id = x: x;
@@ -60,8 +60,8 @@ let
# Export nixpkgs and standard library lib
pkgs = nixpkgs;
- lib = nixpkgs.lib;
- stage = nixpkgs.stdenvNoCC.mkDerivation;
+ lib = nixpkgs.lib // { types = types; };
+ stage = nixpkgs.stdenv.mkDerivation;
# splitting/joining
splitFile = file: drv: stage {