aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-02-06 11:41:23 +1100
committerJustin Bedo <cu@cua0.org>2019-02-06 11:43:23 +1100
commitde57ab52a839ffbd5eee90aca29d6042b4911ed2 (patch)
tree590c2a2fe3148aed22b509d4a0b326879943e30f /default.nix
parent8e466df452e33cc2102e18c3ee1bdcf7e0ea189f (diff)
qsub: rename flags to qsubFlags to avoid collision
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index bd68277..4f16640 100644
--- a/default.nix
+++ b/default.nix
@@ -32,7 +32,7 @@ let
strelka = callBionix ./tools/strelka.nix {};
qsub = attrs: bionix.extend (self: super: with self; rec {
- qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; queue = null; flags = null; } // attrs;
+ qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; queue = null; qsubFlags = null; } // attrs;
qsub = attrs: (callPackage ./lib/qsub.nix {}) (qsubDefs // attrs);
exec = f: x: y: qsub (builtins.intersectAttrs qsubDefs x) (f (builtins.removeAttrs x (builtins.attrNames qsubDefs)) y);
});