aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-04-18 11:33:52 +1000
committerJustin Bedo <cu@cua0.org>2019-04-18 19:00:53 +1000
commite9b908b0cdc22a7b43301e63a23c7911aa371721 (patch)
treee000b0817ca7cac0e839b98aec738cbcb7fe1649 /default.nix
parent0c09091762accf8716ef7853dded34e1c86497aa (diff)
sbatch: initial slurm implementation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 604badb..608fa9b 100644
--- a/default.nix
+++ b/default.nix
@@ -34,6 +34,11 @@ let
strelka = callBionix ./tools/strelka.nix {};
ascat = callBionix ./tools/ascat.nix {};
+ sbatch = attrs: bionix.extend (self: super: with self; rec {
+ sbatchDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; partition = null; slurmFlags = null; } // attrs;
+ sbatch = attrs: (callPackage ./lib/sbatch.nix {}) (sbatchDefs // attrs);
+ exec = f: x: y: sbatch (builtins.intersectAttrs sbatchDefs x) (f (builtins.removeAttrs x (builtins.attrNames sbatchDefs)) y);
+ });
qsub = attrs: bionix.extend (self: super: with self; rec {
qsubDefs = { ppn = 1; mem = 1; walltime = "24:00:00"; tmpDir = "/tmp"; sleepTime = 60; queue = null; qsubFlags = null; } // attrs;
qsub = attrs: (callPackage ./lib/qsub.nix {}) (qsubDefs // attrs);