aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-16 16:31:45 +1000
committerJustin Bedo <cu@cua0.org>2019-05-16 16:31:45 +1000
commitfaa64f72447c26706e2c15c02f70443c7b325091 (patch)
tree70f7a4b422db3a3dced6a90450086ca2a76b3826 /default.nix
parentc79119614ac4f440cd5ac9ff79f12a40753cfb28 (diff)
stage: fix multicore tagging to work with derivation overriding
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 03869bc..575d176 100644
--- a/default.nix
+++ b/default.nix
@@ -75,8 +75,8 @@ let
# Export nixpkgs and standard library lib
pkgs = nixpkgs;
lib = nixpkgs.lib // { types = types; shard = callBionix ./lib/shard.nix {};};
- stage = x@{ name, stripStorePaths ? true, ... }:
- (if stripStorePaths then strip else x: x) ({ multicore = false; } // nixpkgs.stdenvNoCC.mkDerivation (x // {name = "bionix-" + name; }));
+ stage = x@{ name, stripStorePaths ? true, multicore ? false, ... }:
+ (if stripStorePaths then strip else x: x) (nixpkgs.stdenvNoCC.mkDerivation (x // {name = "bionix-" + name; inherit multicore;}));
strip = drv: drv.overrideAttrs (attrs: {
buildCommand = attrs.buildCommand + ''
@@ -96,7 +96,7 @@ let
rewriteOutput $o
done
'';
- });
+ });
# splitting/joining
splitFile = file: drv: stage {