aboutsummaryrefslogtreecommitdiff
path: root/doc/tools-doc.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-03-06 11:43:19 +1100
committerJustin Bedo <cu@cua0.org>2019-03-06 11:43:19 +1100
commita86ef4eda927c47791dc0c25852c13ea622f809b (patch)
treee4604cde726ee8d078bb4f62f331ac0f1c256360 /doc/tools-doc.nix
parente81641608ffd0b08b8da0d1bf0546bc92d3b4088 (diff)
draft API docs for BWA and strelka
Diffstat (limited to 'doc/tools-doc.nix')
-rw-r--r--doc/tools-doc.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/doc/tools-doc.nix b/doc/tools-doc.nix
new file mode 100644
index 0000000..b2cd7ba
--- /dev/null
+++ b/doc/tools-doc.nix
@@ -0,0 +1,41 @@
+{ bionix ? import ./.. {} }:
+
+with bionix;
+
+stage {
+ name = "tools-docs";
+ src = ../tools;
+
+ xsltFlags = lib.concatStringsSep " " [
+ #"--param section.autolabel 1"
+ #"--param section.label.includes.component.label 1"
+ #"--stringparam html.stylesheet 'style.css overrides.css highlightjs/mono-blue.css'"
+ #"--stringparam html.script './highlightjs/highlight.pack.js ./highlightjs/loader.js'"
+ #"--param xref.with.number.and.title 1"
+ #"--param toc.section.depth 3"
+ #"--stringparam admon.style ''"
+ #"--stringparam callout.graphics.extension .svg"
+ ];
+
+
+ buildInputs = with pkgs; [ nixdoc libxslt libxml2 ];
+ installPhase = ''
+ function docgen {
+ nixdoc -c "$1" -d "$2" -f "$1.nix" | sed 's/lib\./bionix./g' |grep -v locations.xml > "$1.xml"
+ }
+
+ docgen bwa 'BWA aligner'
+ docgen strelka 'Strelka2 variant caller'
+
+ mkdir $out
+ cp ${./tools.xml} tools.xml
+ xmllint --nonet --xinclude --noxincludenode tools.xml --output tools-full.xml
+ cat tools-full.xml
+ xsltproc $xsltFlags \
+ --nonet \
+ --xinclude \
+ --output $out/index.html \
+ ${pkgs.docbook_xsl_ns}/xml/xsl/docbook/epub/docbook.xsl \
+ tools-full.xml
+ '';
+}