aboutsummaryrefslogtreecommitdiff
path: root/doc/tools-doc.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-06-11 16:44:36 +1000
committerJustin Bedo <cu@cua0.org>2019-06-11 18:23:29 +1000
commitd12f635279ec1b43a57293c9c95919a489606d8c (patch)
tree85339d6ca9fdbcc1a80a4963ee59ea557155ee8a /doc/tools-doc.nix
parentdc448fa97dfc683ccd491fc4a00e58b6d0f150ef (diff)
rewrite README documentation
Significant expansion of README to include installation instructions and instructions on how to use with HPC.
Diffstat (limited to 'doc/tools-doc.nix')
-rw-r--r--doc/tools-doc.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/doc/tools-doc.nix b/doc/tools-doc.nix
deleted file mode 100644
index d68a6b1..0000000
--- a/doc/tools-doc.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ bionix ? import ./.. {} }:
-
-with bionix;
-
-stage {
- name = "tools-docs";
- src = ../tools;
-
- xsltFlags = lib.concatStringsSep " " [
- #"--param section.autolabel 1"
- #"--param section.label.includes.component.label 1"
- #"--stringparam html.stylesheet 'style.css overrides.css highlightjs/mono-blue.css'"
- #"--stringparam html.script './highlightjs/highlight.pack.js ./highlightjs/loader.js'"
- #"--param xref.with.number.and.title 1"
- #"--param toc.section.depth 3"
- #"--stringparam admon.style ''"
- #"--stringparam callout.graphics.extension .svg"
- ];
-
-
- buildInputs = with pkgs; [ nixdoc libxslt libxml2 ];
- installPhase = ''
- function docgen {
- nixdoc -c "$1" -d "$2" -f "$1.nix" | sed 's/lib\./bionix./g' |grep -v locations.xml > "$1.xml"
- }
-
- docgen ascat 'ascatNGS CNV caller'
- docgen bowtie 'Bowtie aligner'
- docgen bwa 'BWA aligner'
- docgen cnvkit 'CNVkit CNV caller'
- docgen facets 'Facets CNV caller'
- docgen fastqc 'FastQC quality control'
- docgen gridss 'GRIDSS SV caller'
- docgen strelka 'Strelka2 variant caller'
-
- mkdir $out
- cp ${./tools.xml} tools.xml
- xmllint --nonet --xinclude --noxincludenode tools.xml --output tools-full.xml
- cat tools-full.xml
- xsltproc $xsltFlags \
- --nonet \
- --xinclude \
- --output $out/index.html \
- ${pkgs.docbook_xsl_ns}/xml/xsl/docbook/epub/docbook.xsl \
- tools-full.xml
- '';
-}