aboutsummaryrefslogtreecommitdiff
path: root/example/call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2018-11-27 12:50:46 +1100
committerJustin Bedo <cu@cua0.org>2018-11-27 12:51:19 +1100
commitfce03fcbdbea445bc058348db30ccb99274d3f96 (patch)
tree7ce6e6a0f674e0655fe210b85596670e01d76a43 /example/call.nix
parent342df165afb5961557d61bb4cb9a39b88b22d220 (diff)
Expand README and add simple example pipeline
Diffstat (limited to 'example/call.nix')
-rw-r--r--example/call.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/example/call.nix b/example/call.nix
new file mode 100644
index 0000000..c9be673
--- /dev/null
+++ b/example/call.nix
@@ -0,0 +1,19 @@
+# This is an example pipeline specification to do multi-sample variant calling
+# with the Platypus variant caller. Each input is preprocessed by aligning
+# against a reference genome (defaults to GRCH38), fixing mate information, and
+# marking duplicates. Finally platypus is called over all samples.
+{bionix ? import <bionix> {}
+,nixpkgs ? import <nixpkgs> {}
+,inputs
+,ref ? null}:
+
+with bionix;
+
+let
+ preprocess = f:
+ samtools.markdup {}
+ (samtools.sort {}
+ (samtools.fixmate {}
+ (bwa.align {ref = if ref == null then bionix.ref.grch38.seq else ref;} f)));
+
+ in platypus.call {} (map preprocess inputs)