aboutsummaryrefslogtreecommitdiff
path: root/examples/call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-03-27 10:59:44 +1100
committerJustin Bedo <cu@cua0.org>2020-03-27 10:59:44 +1100
commitd4fe5ce2aaea3f951fe21094ccfa90360c12c760 (patch)
tree7a13fa9590fa70271c4da465ae02b6bca1e1879e /examples/call.nix
parent7a80f94a3aa69072e25b92098a746778707cb7d6 (diff)
update exampes to use nixpkgs.lib.pipe
Diffstat (limited to 'examples/call.nix')
-rw-r--r--examples/call.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/call.nix b/examples/call.nix
index 0e4ea05..90832ee 100644
--- a/examples/call.nix
+++ b/examples/call.nix
@@ -7,9 +7,10 @@
,ref ? bionix.ref.grch38.seq }:
with bionix;
+with lib;
let
- preprocess = pipe [
+ preprocess = flip pipe [
(bwa.align { inherit ref; })
(samtools.fixmate {})
(samtools.sort {})