aboutsummaryrefslogtreecommitdiff
path: root/examples/call.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2021-07-28 08:07:32 +1000
committerJustin Bedo <cu@cua0.org>2021-07-28 09:17:56 +1000
commited98174bbefc85f9895c870fdb7518e2a534a150 (patch)
tree913c1eb5cb384213d22af6cf4f4e2b8fd2a51276 /examples/call.nix
parent134f5e0bfcd5f22e3adee4b707e10693cf71e635 (diff)
bugfix: use unsorted type for alignment output
Most aligners are only pseudo-name sorted (i.e., pairs adjacant).
Diffstat (limited to 'examples/call.nix')
-rw-r--r--examples/call.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/call.nix b/examples/call.nix
index 8c4f073..8a38fdb 100644
--- a/examples/call.nix
+++ b/examples/call.nix
@@ -12,6 +12,7 @@ with lib;
let
preprocess = flip pipe [
(bwa.align { inherit ref; })
+ (samtools.sort { nameSort = true; })
(samtools.fixmate {})
(samtools.sort {})
(samtools.markdup {})