aboutsummaryrefslogtreecommitdiff
path: root/examples/ex-tnpair/cluster.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-04-10 09:47:44 +1000
committerJustin Bedo <cu@cua0.org>2020-04-10 09:47:44 +1000
commitcdb7056a14915354d879c519dd396204e4af3959 (patch)
tree8eb04d09f00c1c29455c9344c43307c85be8ebad /examples/ex-tnpair/cluster.nix
parentd4fe5ce2aaea3f951fe21094ccfa90360c12c760 (diff)
update tnpair example to run on colo828
Diffstat (limited to 'examples/ex-tnpair/cluster.nix')
-rw-r--r--examples/ex-tnpair/cluster.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/ex-tnpair/cluster.nix b/examples/ex-tnpair/cluster.nix
new file mode 100644
index 0000000..d7537b2
--- /dev/null
+++ b/examples/ex-tnpair/cluster.nix
@@ -0,0 +1,25 @@
+{ bionix ? import <bionix> { }, tmpDir ? null }:
+
+let
+ bionix' = (bionix."${if tmpDir == null then "slurm" else "qsub"}" {
+ ppn = 24;
+ mem = 7;
+ walltime = "3:00:00";
+ } // bionix.lib.optionalAttrs (tmpDir != null) { inherit tmpDir; }).extend
+ (self: super:
+ with self; {
+ minimap2.align = def super.minimap2.align {
+ mem = 15;
+ walltime = "16:00:00";
+ };
+ samtools = super.samtools // (with super.samtools; {
+ markdup = def markdup { walltime = "12:00:00"; };
+ fixmate = def fixmate { walltime = "10:00:00"; };
+ sort = def sort {
+ mem = 27;
+ flags = "-m 1G";
+ };
+ });
+ });
+
+in import ./. { bionix = bionix'; }